Bug in sin 1.04

Page 3 of 3 Previous  1, 2, 3

View previous topic View next topic Go down

Re: Bug in sin 1.04

Post by fierygod on 23.03.09 20:45

tropikul wrote:ohoh! can anybody put up the skill triggers for ghost trail clan? thanks !!
I think you post this in the wrong section haha.
Anyway try this one made by jack75 : http://illusion.powerguild.net/general-discussions-f11/post-your-data-t13.htm#565

fierygod
Newbie
Newbie

Male
Number of posts : 44
Age : 27
Location : Somewhere on earth xD
Points : 53
Reputation : 3
Join date : 2009-03-17

Back to top Go down

Re: Bug in sin 1.04

Post by Guest on 23.03.09 20:55

oops~
thanks alot fiery!

Guest
Guest


Back to top Go down

Re: Bug in sin 1.04

Post by fierygod on 24.03.09 5:48

your are welcome Very Happy

fierygod
Newbie
Newbie

Male
Number of posts : 44
Age : 27
Location : Somewhere on earth xD
Points : 53
Reputation : 3
Join date : 2009-03-17

Back to top Go down

Re: Bug in sin 1.04

Post by Guest on 25.03.09 15:34

hmmm i think i got a better understanding of things are "going wrong" now that i opened up the program and can see the code. The program works 100%. Any "failed to start" issues are infact improper timers done due to not setting it up properly. Now that i see how it works, i can see that about 90% of everyone will set this up incorrectly since we are used to the programs "doing it for us". You can just click "use basic kozo quick slots" and have it run for 3 days like i was doing. It will work that way (for the most part). Its when ppl try and add skills that the program has not yet learned. I think the real issues are that people are running the program and attaching and pressing "go" and expecting it to .. well... go. It doesnt work like that (reason i had to run with all options OFF to run properly). Its a learning program, not a "pre-defined program" as we are used to. Anyone having issues getting this thing running and going properly please look back to the Help and Guides section and download the triggers for your clan. Im using the SkyTone one and i couldnt get the "no data" thing to go away, so i removed those from my list (skill list) and added 2 more for my level (attacks). A small re-adjustment of distance and whatnot (double checking to make sure everything was in order and correct) and SIN 1.04 is running 100% and buffing and healing and everything.
I think one of the main issues people are having is assuming the program is setup with predefines skills and triggers, and its not at all. We are used to saying "oh i have this skill" and "checking the box" and saying "yay im setup now!" and thats the improper way to do this bot, as you will find with the small "glitches" you will run across.
Im running 1 bot 2 accounts and its a tad laggy (local lag AKA crappy video card) but its running them fine. A friends running same options as me and he has to log out of the game everytime he stops the program before it will run again. We are setting up the skills as i did and hecking to see if it works, will edit post to submit how things go.

My Computer:
Account 1 = PASS
Account 2 = PASS

Friends Computer:
Account 1 = Fail


Last edited by darkfayte on 25.03.09 16:05; edited 1 time in total

Guest
Guest


Back to top Go down

Re: Bug in sin 1.04

Post by vuduy on 25.03.09 15:45

Woah, you can open and see the codes of the program? You must be really good.

vuduy
Administrator
SINBOT Creator


AdministratorSINBOT Creator

Male
Number of posts : 1033
Age : 40
Points : 1429
Reputation : 107
Join date : 2007-11-15

Back to top Go down

Re: Bug in sin 1.04

Post by Guest on 25.03.09 15:49

ahh yeah there are like 500 programs to open EXE files and see the code inside

Guest
Guest


Back to top Go down

Re: Bug in sin 1.04

Post by vuduy on 25.03.09 15:50

you mean the asm? or the net assembly?

vuduy
Administrator
SINBOT Creator


AdministratorSINBOT Creator

Male
Number of posts : 1033
Age : 40
Points : 1429
Reputation : 107
Join date : 2007-11-15

Back to top Go down

Re: Bug in sin 1.04

Post by Guest on 25.03.09 15:55

not the net ..
i open this program and it opens the EXE so i can read each line of whats inside ... some of it isnt english/readable ...

Guest
Guest


Back to top Go down

Re: Bug in sin 1.04

Post by vuduy on 25.03.09 15:58

What program you used? And you actually understand that crap?
Can you open elementclient.exe and help me locate the function that handles trading between players? I'm having trouble with this.

vuduy
Administrator
SINBOT Creator


AdministratorSINBOT Creator

Male
Number of posts : 1033
Age : 40
Points : 1429
Reputation : 107
Join date : 2007-11-15

Back to top Go down

Re: Bug in sin 1.04

Post by Guest on 25.03.09 17:50

PM sent
let me look up what API and other functions they use in this game

Guest
Guest


Back to top Go down

Re: Bug in sin 1.04

Post by vuduy on 25.03.09 18:07

You can write in here, no need for PM; and I hope you know what you are doing.

vuduy
Administrator
SINBOT Creator


AdministratorSINBOT Creator

Male
Number of posts : 1033
Age : 40
Points : 1429
Reputation : 107
Join date : 2007-11-15

Back to top Go down

Re: Bug in sin 1.04

Post by Guest on 25.03.09 18:09

Updating as i fond info out

Update 1
Game uses LUA 5.1
this is very good for people that can do LUA and XML programming / addon programming --- moving on

Full list of STRINGS for the elementalclient.exe

elementclient.exe.str.txt
http://www.mediafire.com/?rzww1wwzjkn

getting what you need now - takes a while to decompile it
---- still working on it, i keep getting a lot of errors for some reason ----

Guest
Guest


Back to top Go down

Re: Bug in sin 1.04

Post by vuduy on 25.03.09 20:34

Error? why would there be any error? the file runs fine. Are you sure you know what you're doing? and strings are quite useless; i need actual function or offset.

vuduy
Administrator
SINBOT Creator


AdministratorSINBOT Creator

Male
Number of posts : 1033
Age : 40
Points : 1429
Reputation : 107
Join date : 2007-11-15

Back to top Go down

Re: Bug in sin 1.04

Post by Guest on 25.03.09 21:50

vuduy wrote:Error? why would there be any error? the file runs fine. Are you sure you know what you're doing? and strings are quite useless; i need actual function or offset.

im 100% sure since i have removed any security process from your SIN.EXE (user name and password) im 10000% sure i know what im doing. The error was not in your program (SIN) it was in the decompile process that was reading 5 offsets that were incorrect in the Elementclient.EXE Go ahead and decompile yourself and see those 5 errors, they are there. I'm still working on getting this issue solved, im not sure whats causeing the error (in the client not SIN) for the offsets ... but since ppl are busting down doors for more features.. im in no rush.

Wrote a LUA/XML to add-on your program, opens trades and venders selected loots & auto invites to party. XML/LUA > memory sniffers

prove my point:

SIN.exe
File Headers
DOS EXE:true
NT EXE:true
Dos STUB size:64 bytes
DOS Header
e_magic:5a4dh (23,117)
e_cblp:90h (144)
e_cp:3h (3)
e_crlc:0h (0)
e_cparhdr:4h (4)
e_minalloc:0h (0)
e_maxalloc:ffffh (65,535)
e_ss:0h (0)
e_sp:b8h (184)
e_csum:0h (0)
e_ip:0h (0)
e_cs:0h (0)
e_lfarlc:40h (64)
e_ovno:0h (0)
e_res:0h (0)
e_oemid:0h (0)
e_oeminfo:0h (0)
e_res2:0h (0)
e_lfanew:80h (128)

COFF File Header (Object & Image)
Machine:Intel 386 or later, and compatible processors
NumberOfSections:3h (3)
TimeDateStamp:Wed Mar 25 13:50:58 CDT 2009
PointerToSymbolTable:0h (0)
NumberOfSymbols:0h (0)
SizeOfOptionalHeader:e0h (224)
Characteristics:IMAGE_FILE_EXECUTABLE_IMAGE, IMAGE_FILE_32BIT_MACHINE

Optional Header (Usually Image Only)
PE Format:PE32
Standard fields
MajorLinkerVersion:8h (Cool
MinorLinkerVersion:0h (0)
SizeOfCode:4bc00h (310,272)
SizeOfInitializedData:4a00h (18,944)
SizeOfUninitializedData:0h (0)
AddressOfEntryPoint:3ad88h (241,032)
BaseOfCode:8000h (32,768)
BaseOfData:2000h (8,192)
NT additional fields
ImageBase:400000h (4,194,304)
SectionAlignment:2000h (8,192)
FileAlignment:200h (512)
MajorOperatingSystemVersion:4h (4)
MinorOperatingSystemVersion:0h (0)
MajorImageVersion:0h (0)
MinorImageVersion:0h (0)
MajorSubsystemVersion:4h (4)
MinorSubsystemVersion:0h (0)
SizeOfImage:56000h (352,256)
SizeOfHeaders:200h (512)
CheckSum:528dfh (338,143)
Subsystem:Image runs in the Windows graphical user interface (GUI) subsystem
DllCharacteristics:IMAGE_FILE_REMOVABLE_RUN_FROM_SWAP
SizeOfStackReserve:100000h (1,048,576)
SizeOfStackCommit:1000h (4,096)
SizeOfHeapReserve:100000h (1,048,576)
SizeOfHeapCommit:1000h (4,096)
LoaderFlags:0h (0)
NumberOfRvaAndSizes:10h (16)

Optional Header Data Directories (Image Only)

Export Table
VirtualAddress:0h (0)
Size:0h (0)

Import Table
VirtualAddress:3ad50h (240,976)
Size:58h (88)

Resource Table
VirtualAddress:2000h (8,192)
Size:4608h (17,928)

Exception Table
VirtualAddress:0h (0)
Size:0h (0)

Certificate Table
VirtualAddress:0h (0)
Size:0h (0)

Base Relocation Table
VirtualAddress:54000h (344,064)
Size:ch (12)

Debug
VirtualAddress:0h (0)
Size:0h (0)

Architecture
VirtualAddress:0h (0)
Size:0h (0)

Global Ptr
VirtualAddress:0h (0)
Size:0h (0)

TLS Table
VirtualAddress:0h (0)
Size:0h (0)

Load Config Table
VirtualAddress:0h (0)
Size:0h (0)

Bound Import
VirtualAddress:0h (0)
Size:0h (0)

IAT
VirtualAddress:3ad78h (241,016)
Size:8h (Cool

Delay Import Descriptor
VirtualAddress:0h (0)
Size:0h (0)

COM+ Runtime Header
VirtualAddress:3d978h (252,280)
Size:48h (72)

Reserved
VirtualAddress:0h (0)
Size:0h (0)

Section Table (Section Headers)[3]

.rsrc
VirtualSize:4608h (17,928)
VirtualAddress:2000h (8,192)
SizeOfRawData:4800h (18,432)
PointerToRawData:200h (512)
PointerToRelocations:0h (0)
PointerToLinenumbers:0h (0)
NumberOfRelocations:0h (0)
NumberOfLinenumbers:0h (0)
Characteristics:40000040h (1,073,741,888)
Characteristics:Section contains initialized data, Section can be read

.text
VirtualSize:4bbb8h (310,200)
VirtualAddress:8000h (32,768)
SizeOfRawData:4bc00h (310,272)
PointerToRawData:4a00h (18,944)
PointerToRelocations:0h (0)
PointerToLinenumbers:0h (0)
NumberOfRelocations:0h (0)
NumberOfLinenumbers:0h (0)
Characteristics:60000020h (1,610,612,768)
Characteristics:Section contains executable code, Section can be executed as code, Section can be read

.reloc
VirtualSize:ch (12)
VirtualAddress:54000h (344,064)
SizeOfRawData:200h (512)
PointerToRawData:50600h (329,216)
PointerToRelocations:0h (0)
PointerToLinenumbers:0h (0)
NumberOfRelocations:0h (0)
NumberOfLinenumbers:0h (0)
Characteristics:42000040h (1,107,296,320)
Characteristics:Section contains initialized data, Section can be discarded as needed, Section can be read


there is the basic info for your SIN.exe program

Guest
Guest


Back to top Go down

Re: Bug in sin 1.04

Post by vuduy on 25.03.09 21:54

You removed username/password requirement from SIN? Okay let me see if you can use the program now. Close SIN, and restart it... Good luck Smile

EDIT: FYI, if I haven't decompiled elementclient.exe, do you think I could make a bot like this? I'll tell you what; if you admit that you have no fucking clue what you are doing other than posting all these junks from PE explorer; I'll consider giving back your access in 3 days.

Or wait... unless you already removed username/password, so I guess you won't need it. :bball:

vuduy
Administrator
SINBOT Creator


AdministratorSINBOT Creator

Male
Number of posts : 1033
Age : 40
Points : 1429
Reputation : 107
Join date : 2007-11-15

Back to top Go down

Re: Bug in sin 1.04

Post by puka on 25.03.09 22:43

damn he removed himself from SIN group :bounce: :bounce: :bounce:

puka
CuuLe Moderator
CuuLe Moderator

Number of posts : 147
Age : 29
Points : 194
Reputation : 13
Join date : 2009-03-19

Back to top Go down

Re: Bug in sin 1.04

Post by jack75 on 25.03.09 22:53

you know what?

that was hillarious! lol!

jack75
Supper Botter
Supper Botter

Male
Number of posts : 231
Age : 41
Points : 250
Reputation : 2
Join date : 2009-03-18

Back to top Go down

Re: Bug in sin 1.04

Post by Guest on 26.03.09 19:27

about bugs though... i noticed this after 1.02, 1.03 for me cux 1.04 didn't work for x64... now i also see it 1.05. it doesn't seem to loot all the things you want it to loot especially when multiple items in your loot list drop at the same time.

For example you set it to loot silk and wood, then a mob dies dropping 1 of each. it'll only pick up one. i think it happened when the delay got taken out. just a though. it works great. the inventory's full so i guess over night it's all the same.

Thanks for the great bot by the way.

Guest
Guest


Back to top Go down

Re: Bug in sin 1.04

Post by Guest on 27.03.09 8:37

airuerue wrote:about bugs though... i noticed this after 1.02, 1.03 for me cux 1.04 didn't work for x64... now i also see it 1.05. it doesn't seem to loot all the things you want it to loot especially when multiple items in your loot list drop at the same time.

For example you set it to loot silk and wood, then a mob dies dropping 1 of each. it'll only pick up one. i think it happened when the delay got taken out. just a though. it works great. the inventory's full so i guess over night it's all the same.

Thanks for the great bot by the way.

ya ya.. i agree with u.. i thought it only happened to me...

Guest
Guest


Back to top Go down

Re: Bug in sin 1.04

Post by vuduy on 27.03.09 8:55

It should pick up all. If you are in party, make sure it's Free for all. By default, it's by Rotation; if you play with rotation, and someone's bag is full, loot will be dropped on ground and nobody can pickup... SIN will wait there a bit keep trying to pick up.

So remember to change to Free for all.

vuduy
Administrator
SINBOT Creator


AdministratorSINBOT Creator

Male
Number of posts : 1033
Age : 40
Points : 1429
Reputation : 107
Join date : 2007-11-15

Back to top Go down

Re: Bug in sin 1.04

Post by Guest on 27.03.09 19:31

i just observed the bot more and it seems to work real nice (looting) when the loor range slider is maxed Smile thanks again for the great upload

Guest
Guest


Back to top Go down

Re: Bug in sin 1.04

Post by Guest on 28.03.09 19:40

im a lier and i dont know what im doing, your right ...
i was bullshitting and have no idea wtf im doing

Guest
Guest


Back to top Go down

Re: Bug in sin 1.04

Post by fierygod on 29.03.09 0:50

lol i hope you learnt your lesson

fierygod
Newbie
Newbie

Male
Number of posts : 44
Age : 27
Location : Somewhere on earth xD
Points : 53
Reputation : 3
Join date : 2009-03-17

Back to top Go down

Re: Bug in sin 1.04

Post by Guest on 30.03.09 12:07

Sometime SIN usually targets my own pet Shocked that only happens when there's someone ks me Suspect

Guest
Guest


Back to top Go down

Re: Bug in sin 1.04

Post by Guest on 31.03.09 20:59

damn you have pets already >_< i wonder when ph will get pets and the other in-game features... but just in case the update today gives us pets, i'll check if it happens to me too.Very Happy

Guest
Guest


Back to top Go down

Re: Bug in sin 1.04

Post by Sponsored content Today at 3:12


Sponsored content


Back to top Go down

Page 3 of 3 Previous  1, 2, 3

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum